list of current glitches/errors on the new forum

Topic created · 11 Posts · 124 Views
  • Figured I’d make a thread for us members to help with getting everything functional and any glitches ironed out. Here are a few things that I’ve noticed:

    -Avatars cannot be uploaded/changed (button isn’t functional) EDIT: works on Chrome, Firefox no bueno EDIT 2: holy FUCK the circle avatars have got to go, it’s impossible to properly crop and it makes the image so fucking blurry. spent like 10 mins trying to upload an avi and every time it wouldnt crop right, even tried using paint to create more border area and it just made the avi look whack

    -Every time I click anything I get a pop up in the bottom right hand corner with “Looks like your connection to Steroid Source Talk was lost, please wait while we try to reconnect.”

    -Often when I click something like compose, submit, edit, etc. nothing happens and I have to open it in a new tab for anything to occur.

    -There is always this spinning ‘loading’’ icon to the left of the search and alert icons at the top EDIT: Doesn’t happen on Chrome, Firefox no bueno

    -When I went to reset my password it would not work until I went onto a private tab

    -I couldn’t post a thread on Firefox, had to switch to Chrome

    This is in no way meant to be some form of criticism or complaint, merely me trying to help identify problems that need solving during the transition onto the new board. I appreciate all of the work y’all do for us.

  • The whole fuckin migration has been a shitshow. The site had the wrong SSL certificate for two days, we’ve gone back and forth from old to new twice, the website was down again for like 10 hours yesterday and I just managed to post for the first time since the switch to the new site because the “Reset Password” functionality is FUBAR on Desktop. I had to reset password on my phone because on both Chrome and Firefox Desktop the whole fuckin site bugs out with some permaloading thing at the top right and a “Looks like your connection to Steroid Source Talk was lost, please wait while we try to reconnect” popup bottom right. I’m pretty sure this is extremely widespread because the board has been completely dead for days now.

    Also the redesign looks like shit and is much harder to navigate than the previous version.

  • At this point it seems like we’re gonna end up shuttled onto the Discord (I still don’t even know how to use that) with the forum being all messed up. I miss early 2000s when forums were simple to set up and anyone could do it from free websites lol

  • Wow finally managed to get in thanks to the above directions. Tried to reset my password via desktop every which way. Looked at the html, there is a big “onsubmit=return false” in the form which Im guessing is why when I click the reset button with an email in the form, nothing happens on desktop. I repeat, THE RESET FUNCTIONALITY IS COMPLETELY BROKEN ON DESKTOP.

    I even tried copying the curl post when you try to login and apply that to the reset link to hack my way into resetting my password and that didnt work either.

    On my phone navigating to “steroidsourcetalk.org” leads me to a “this site can’t be reached - ERR_CONNECTION_REFUSED” because I’m assuming its trying to take me to http://steroidsourcetalk.org and you guys don’t have the proper redirects setup to take me to the ssl version of the site so I’m left with a broken page. I had to manually type “https:…etc” to even get to the page via mobile.

    Luckily the reset password form works when you finally even manage to get the site to load. There are a lot of things broken here, and instead of bitching and complaining and moaning, I’d love to try to help get things together as I’m a software engineer so I deal with bullshit like this all the time.

    Please pm me so I can try to help you guys get the site going, its completely dead here and I’m assuming everyone else is having as much trouble as I did trying to even login.

    Regards,

    fractal

  • @fractal
    Not sure if there’s much point in talking about this here but it’s not because of the onsubmit=return false, it’s because of NodeBB’s cross-site websocket hijacking protection.

    Open up the dev tools in your browser of choice and go to https://www.steroidsourcetalk.org/reset then look at the console, you’ll see a SPAM of 403 forbidden requests to a new websocket that SST now uses: https://i.imgur.com/4Gdmgfx.jpg

    Now, go to https://steroidsourcetalk.org/reset (see the difference? no www.) and do the same thing. No more spam. The password reset function now works.

    Basically in NodeBB’s configuration, they have to set the “allowed domain” that the source can be from and they’ve only set it to steroidsourcetalk.org and there’s no redirect from www.steroidsourcetalk.org. More info @ https://community.nodebb.org/topic/13388/faq-websockets-not-working-due-to-misconfigured-origins

    EDIT: I guess there was a point because as of 40 minutes after typing this post, the websocket is now fixed and works on both URLs after a week of not working. I’ll take all the credit, thanks.

  • @fractal @ForgotMuhName @rpolitics_sucks

    We did work very hard on the site and there are several reasons why it is better than the old forum. We do apologize very much for the delays and errors in getting it up and running. Those were completely unexpected. We do believe them to be fixed moving forward.

    @kingofcarbz Thank you for starting this post. Appreciate the assist there and hopefully all those things are ironed out now. Do try the avatar and profile page. Mine is obviously myself as a Simpson lol

  • Thanks @rpolitics_sucks , I did see those in the console, that makes sense! Glad you guys are getting things together here, hope this forum stays up and chugging along. I appreciate the effort to keep it going.

  • @ForgotMuhName said in list of current glitches/errors on the new forum:

    At this point it seems like we’re gonna end up shuttled onto the Discord (I still don’t even know how to use that) with the forum being all messed up. I miss early 2000s when forums were simple to set up and anyone could do it from free websites lol

    Dude me too, man. Anyone could get a quick VPN or shared hosting package, toss up PhpBB or VBulletin, and it was ready to go out the box. I get that SST may want some precautions in place due to the nature of what we’re all doing here, and they’re quickly growing, so this change must have been forced. At least SST is in the open and we don’t need to go through TOR

  • @CaptainAmerica No problem amigo. It worked fine button function wise and everything, but the circle cuts off part of the image even when you use the cropping tool just because of the shape it’s in relative to how images are shaped - I feel like squares are better for simplicity sake, but it’s all personal preference I guess. Just throwing out my input, obviously I’m only one opinion out of many. Also, it’s kind of annoying how when you go to reply you get a pop-up window instead of actually replying directly on the post itself. Not sure if that’s a feature you guys can change, but I find it to be unnecessary. Or instead of outright removing either, maybe making them options - square or circle avi., pop-up or built in reply box. Not sure how much can be done in terms of like, changing/adding features and all that so excuse my ignorance if anything isn’t possible.

  • I just now finally got back into the site after trying off and on since the new forum came up. I’m not sure what the magical combination was for password reset requests, phase of the moon, or day of the week, so I can’t really repeat back to anybody that’s still having trouble what they might need to do. The most frustrating part was how completely useless the admins were. When you can’t get logged in to the site, you obviously can’t post to ask for help. The old site used to have a sticky someplace with instructions on how to reach the admins directly, but I couldn’t find it in the new forum. I might have overlooked it, but I did look. I finally reached out to one of the sources I use and asked him if could get me contact info for the admins, and he sent me their email address. I emailed them about my inability to successfully reset my password, but other than inquiring about what email address my profile used, they did nothing. After four days with no response, I prompted them again and was still ignored.

    SST has a great community of users and collectively the best group of sources I’ve dealt with, but I am completely underwhelmed by the admins.

    lunchbeast

  • @lunchbeast said in list of current glitches/errors on the new forum:

    I just now finally got back into the site after trying off and on since the new forum came up. I’m not sure what the magical combination was for password reset requests, phase of the moon, or day of the week, so I can’t really repeat back to anybody that’s still having trouble what they might need to do. The most frustrating part was how completely useless the admins were. When you can’t get logged in to the site, you obviously can’t post to ask for help. The old site used to have a sticky someplace with instructions on how to reach the admins directly, but I couldn’t find it in the new forum. I might have overlooked it, but I did look. I finally reached out to one of the sources I use and asked him if could get me contact info for the admins, and he sent me their email address. I emailed them about my inability to successfully reset my password, but other than inquiring about what email address my profile used, they did nothing. After four days with no response, I prompted them again and was still ignored.

    SST has a great community of users and collectively the best group of sources I’ve dealt with, but I am completely underwhelmed by the admins.

    lunchbeast

    I can understand your frustration, and obviously you didn’t get enough communication from the moderator team to feel satisfied with your inquiry. Can’t argue with that. I would ask that you take into consideration that every single account on this board had the same password reset that yours did, so you can imagine the flood of emails we received. You’ve hit the nail on the head, in my opinion, about the quality of our community and our sources. There are 3 administrators at this time and I can assure you all of our available focus was put on smoothing out the transition. While you may not have received a timely response for your personal password reset, and I apologize for that, all I can say is that we were doing our best. The very fact that you eventually got the password reset email does go to show that the tinkering in the background was being done.

    Hopefully now that your account issues are sorted out you’ll have be able to continue enjoying this board and the community. You may be underwhelmed by the lack of whiteglove service that you personally received from the administrators, but there’s a reason this board has grown to what it is. I believe wholeheartedly that the admin team is a big reason for that.

Log in to reply